There was a recommendation, in April 2013, that all users move their GoCD Server and GoCD Agent installations to Java 7. Oracle and OpenJDK no longer support Java 6. So it is time for GoCD to stop supporting it. 14.2.0 will be last GoCD release which will work with Java 6. Any new GoCD release beyond 14.2.0 might not work with Java 6.

If you have not already moved to Java 7, we request you to do so. Should you face any issues please do write to the community mailing list.